Version 12.0.1 - Esko

These are the minimum requirements for reasonable performance of the described products. They will help you decide whether the equipment you are currently using remains viable. If you are considering new equipment, bear in mind that these requirements are minimum, not optimal. Exceeding these specifications will in general lead to enhanced performance.

Note that Mac OS X 10.9 Mavericks is officially supported from Suite 12 Assembly 5, release date: end January 2014. This applies to the following Esko software packages running on OS X: Automation Engine Pilot, DeskPack, Studio, ArtPro, i-cut Preflight, Neo …
In case the customer has upgraded their Macs to Mavericks, there is a License Manager hotfix available for Suite 12 Assembly 4: https://wiki.esko.com/pages/viewpage.action?pageId=78613702
From the first week of January 2014 onwards, customer can download the installers for all Interactive applications v12.1.2,  i-cut Layout and i-cut Preflight v12.1 (Assembly 5) on https://mysoftware.esko.com


Note that installing and using Esko software on a Terminal Services or Remote Desktop Services server (Microsoft, Citrix,…) is not supported.
Note that using Esko software with local licenses when launched via Remote Desktop is not supported.
Note that Windows Server 2012 Standard and Datacenter are supported from Suite 12.1.1 (Assembly 4). This depends on the Product. Therefore, check the specific product system requirements. Windows Server 2012 Essentials and Foundation are not supported.

See more notes here

Click here to go to the System Requirement page of Previous releases (Esko Software Suite 7 products, Nexus, Odystar...).

 

 

Studio (Designer and Toolkits):  MAC  PC

 

- Studio Toolkit for Labels (Mac and PC)

- Studio Toolkit for Boxes (Mac and PC)

- Studio Toolkit for Flexibles (Mac)

- Studio Toolkit for Shrink Sleeves (Mac and PC)

 

Studio Visualizer:   MAC   PC

 

 

Store Visualizer:     MAC  PC 

 

 


 

 

Studio for MAC:

 

  • CPU:  Mac with Intel processor
  • Memory: Minimum 1GB RAM, recommended 4GB RAM
  • Video Card:  Intel Macs with: NVidia GeForce 6600/6800/7300/7600/7800/8600/8800, Quadro FX 4500/5600 or ATI Radeon 9600/9700/9800, Radeon HD 2400/2600/5770/5870, X600/X800/X1600/X1900, Intel HD Graphics 3000, AMD Radeon HD 6750M/6770M/6950M
  • CD/DVD: DVD-ROM drive
  • Compatibility: If you intend to run other applications as well on this hardware, make sure to check compatibility with the specifications of all other applications as well
  • Remote Support: Esko Customer Support is using TeamViewer as a solution for remote access and support over the Internet, it can be downloaded from http://www.teamviewer.com/download/index.aspx
  • Software Dependency:
    - Studio requires Adobe Illustrator CS5, CS5.5 or CS6 [1]
    - 3D PDFs from Studio Designer require Adobe Reader 8.1 or later for viewing.
    Footnotes:
    [1] Studio Designer is also available in ArtPro 10 or higher.
  • Operating Systems compatibility matrix:

     

    Client OS

    Server OS

    10.1.x NO NO
    10.2.x NO NO
    10.3.x NO NO
    10.4.0 - 10.4.10 (Tiger) NO NO
    10.4.11 (Tiger) NO NO
    10.5.0 - 10.5.7 (Leopard) NO NO
    10.5.8 (Leopard) NO NO
    10.6.0 - 10.6.8 (Snowleopard) YES NO
    10.6.8 (Snowleopard) YES* NO
    10.7 (Lion) YES* NO
    10.8 (Mountain Lion)  YES*
    NO 

* Recommended operating system.
* 10.8 (Mountain Lion) support is only from 12.0.1 Assembly 2 onwards.


 

 

 

Studio for PC:

 

  • Note that Studio Toolkit for Flexibles is currently not available for Windows.
  • CPU: An x86-32 or x86-64 compatible dual-core processor (Intel or AMD), minimum dual-core
  • Memory: Minimum 1GB RAM, recommended 4GB RAM
  • Harddisk: An NTFS volume is required. The software takes maximum 1GB of disk space. But take into account the need for storage of temporary and production data. A backup solution is strongly advised.
  • Network: 10/100/1000 Base-T Ethernet, TCP/IP v4 protocol, TCP/IP v6 protocol is not supported.
  • Video Card: DirectX9 compatible 3D graphics board from ATI or NVidia supporting fragment shaders and with at least 128MB video memory.  Examples are ATI Radeon 9600, 9700, 9800, Radeon X series, Radeon HD series and NVidia GeForce FX series, GeForce 6 series, GeForce 7 series, GeForce 8 series, GeForce 9 series. ATI FireGL boards and Intel embedded graphics are NOT supported.
  • CD/DVD: DVD-ROM drive
  • Virtualization: Parallels Desktop or Vmware Fusion can be used, but not all functionality seems to be working due to restrictions in the virtualization software. Also please be aware that Esko doesn't test all combinations of MacOSX and Parallels Desktop/Vmware Fusion. We discovered that some keyboard and mouse functionality is not working as expected.
  • Fileservers: All Esko applications running on Windows OS can use data that is available on network shares. These shares need to be on Windows or Unix/Linux (using SMB) file servers. Mac OS X (version 10.3.x; 10.4.x; 10.5.x; 10.6.x) data servers are also supported, but with limitations. These are standard limitations encountered when connecting to a Mac OS X server from Windows workstations or servers. They are related to losing resource forks of the MAC-application data when a Windows component moves or copies data.
  • Compatibility: If you intend to run other applications as well on this hardware, make sure to check compatibility with the specifications of all other applications as well
  • Remote Support: Esko Customer Support is using TeamViewer as a solution for remote access and support over the Internet, it can be downloaded from http://www.teamviewer.com/download/index.aspx
  • Software Dependency:
    - Studio requires Adobe Illustrator CS5, CS5.5 or CS6 [1]
    - 3D PDFs from Studio Designer require Adobe Reader 8.1 or later for viewing.
    Footnotes:
    [1] Studio Designer is also available in Esko PackEdge 10, Plato 10 or higher.
  • Operating Systems compatibility matrix:

    Windows XP

    32 bit 64 bit
    SP1 SP2 SP3 SP1 SP2 SP3
    Home Edition NO NO NO YES
    Professional Edition NO NO NO YES* NO NO NO NO


    Windows Vista
    32 bit 64 bit
    SP1 SP2 SP1 SP2
    Windows Vista Starter NO NO NO
    Windows Vista Home Basic NO NO NO NO NO NO
    Windows Vista Home Premium YES YES YES NO NO NO
    Windows Vista Business YES YES YES* NO NO NO
    Windows Vista Enterprise YES YES YES* NO NO NO
    Windows Vista Ultimate YES YES YES* NO NO NO


    Windows 7
    32 bit 64 bit
    SP1 SP1
    Windows 7 Home Basic NO NO NO NO
    Windows 7 Home Premium NO NO NO NO
    Windows 7 Professional YES* YES YES* YES
    Windows 7 Enterprise YES* YES YES* YES
    Windows 7 Ultimate YES* YES YES* YES


    Windows 2000
    32 bit
    SP1 SP2 SP3 SP4
    Windows 2000 Professional NO NO NO NO NO
    Windows 2000 Server NO NO NO NO NO
    Windows 2000 Advanced Server NO NO NO NO NO
    Windows 2000 Datacenter Server NO NO NO NO NO


    Windows Server 2003
    32 bit 64 bit
    SP1 SP2 SP1 SP2
    Windows Server 2003 Standard NO NO NO NO NO NO
    Windows Server 2003 Enterprise NO NO NO NO NO NO
    Windows Server 2003 Datacenter NO NO NO NO NO NO
    Windows Server 2003 R2 Standard NO NO NO NO
    Windows Server 2003 R2 Enterprise NO NO NO NO
    Windows Server 2003 R2 Datacenter NO NO NO NO

    Windows Small Business Server 2003 is not supported
    Windows Server 2003 Web is not supported



    Windows Server 2008
    32 bit 64 bit
    SP2 SP2
    Windows Server 2008 Standard NO NO NO NO
    Windows Server 2008 Enterprise NO NO NO NO
    Windows Server 2008 Datacenter NO NO NO NO

    Windows Small Business Server 2008 is not supported
    Windows Web Server 2008 is not supported
    Windows Server 2008 HPC Edition is not supported



    Windows Server 2008 R2
    64 bit
    SP1
    Windows Server 2008 R2 Standard NO NO
    Windows Server 2008 R2 Enterprise NO NO
    Windows Server 2008 R2 Datacenter NO NO

    Windows Small Business Server 2008 is not supported
    Windows Server 2008 R2 Foundation is not supported.
    Windows Web Server 2008 R2 is not supported
    Windows Server 2008 R2 HPC Edition is not supported

    * recommended Operating system.

  • For more info about Windows memory limitation, please consult this table.

 

 


 

Visualizer for Mac

 

  • Video Card: Intel Macs with: NVidia GeForce 6600/6800/7300/7600/7800/8600/8800, Quadro FX 4500/5600 or AMD/ATI Radeon 9600/9700/9800, Radeon HD 2400/2600, X600/X800/X1600/X1900. A minimum of 256MB video memory is required.
  • A full installation of Apple QuickTime 6.5.1 or later is required. 
  • Memory: Minimum 1GB RAM, recommended 4GB RAM
  • Harddisk: The software takes about 400MB of disk space. Also take into account the need for storage of temporary and production data. A backup solution is strongly advised.
  • Use within Parallels Desktop, Vmware Fusion or any other virtualised environment is NOT supported.
  • Operating Systems compatibility matrix:

     

    Client OS

    Server OS

    10.1.x NO NO
    10.2.x NO NO
    10.3.x NO NO
    10.4.0 - 10.4.10 (Tiger) NO NO
    10.4.11 (Tiger) NO NO
    10.5.0 - 10.5.7 (Leopard) NO NO
    10.5.8 (Leopard) NO NO
    10.6.0 - 10.6.8 (Snowleopard) YES NO
    10.7 (Lion) YES* NO
    10.8 (Mountain Lion)  YES*
    NO 

    * Recommended operating system.
    10.8 (Mountain Lion) support is from Visualizer 12 Assembly 2 onwards.

  • NOTE: Mac computers using GeForce 8600M GT graphics hardware are not supported, as many of them have serious stability issues under heavy graphics load.
  • NOTE: Mac Minis & Mac Books using Intel embedded graphics are not supported.
  • NOTE: PowerPC Macs are not supported.

Visualizer for PC

 

 

  • CPU: An x86-32 or x86-64 compatible dual-core processor (Intel or AMD), minimum dual-core
  • Memory: Minimum 1GB RAM, recommended 4GB RAM
  • Harddisk: An NTFS volume is required. The software takes about 200MB of disk space. Also take into account the need for storage of temporary and production data. A backup solution is strongly advised.
  • Network: 10/100/1000 Base-T Ethernet, TCP/IP v4 protocol, TCP/IP v6 protocol is not supported.
  • Video Card: DirectX9 compatible 3D graphics board from AMD/ATI or NVidia supporting fragment shaders and with at least 256MB video memory. Examples are AMD/ATI Radeon 9600, 9700, 9800, Radeon X series, Radeon HD series and NVidia GeForce FX series, GeForce 6 series, GeForce 7 series, GeForce 8 series, GeForce 9 series. AMD/ATI FireGL boards and Intel embedded graphics are NOT supported.
  • A full installation of Apple QuickTime 6.5.1 or later is required, If you do not have QuickTime on your PC, click below to visit Apple's website and download it. During the QuickTime installation select 'Recommended' (instead of 'Minimum'). Download link: http://www.apple.com/quicktime/download/
  • CD/DVD: DVD-ROM drive
  • Use within Parallels Desktop, Vmware Fusion or any other virtualised environment is NOT supported.
  • Compatibility: If you intend to run other applications as well on this hardware, make sure to check compatibility with the specifications of all other applications as well
  • Remote Support: Esko Customer Support is using TeamViewer as a solution for remote access and support over the Internet, it can be downloaded from http://www.teamviewer.com/download/index.aspx
  • Operating Systems compatibility matrix:

    Windows XP
    32 bit 64 bit
    SP1 SP2 SP3 SP1 SP2 SP3
    Home Edition NO NO NO NO
    Professional Edition YES YES YES YES* NO NO NO NO


    Windows Vista
    32 bit 64 bit
    SP1 SP2 SP1 SP2
    Windows Vista Starter NO NO NO
    Windows Vista Home Basic NO NO NO NO NO NO
    Windows Vista Home Premium NO NO NO NO NO NO
    Windows Vista Business NO NO NO NO NO NO
    Windows Vista Enterprise NO NO NO NO NO NO
    Windows Vista Ultimate NO NO NO NO NO NO


    Windows 7
    32 bit 64 bit
    SP1 SP1
    Windows 7 Home Basic NO NO NO NO
    Windows 7 Home Premium NO NO NO NO
    Windows 7 Professional YES* YES* YES* YES*
    Windows 7 Enterprise YES* YES* YES* YES*
    Windows 7 Ultimate YES* YES* YES* YES*


    Windows 2000
    32 bit
    SP1 SP2 SP3 SP4
    Windows 2000 Professional NO NO NO NO NO
    Windows 2000 Server NO NO NO NO NO
    Windows 2000 Advanced Server NO NO NO NO NO
    Windows 2000 Datacenter Server NO NO NO NO NO


    Windows Server 2003
    32 bit 64 bit
    SP1 SP2 SP1 SP2
    Windows Server 2003 Standard NO NO NO NO NO NO
    Windows Server 2003 Enterprise NO NO NO NO NO NO
    Windows Server 2003 Datacenter NO NO NO NO NO NO
    Windows Server 2003 R2 Standard NO NO NO NO
    Windows Server 2003 R2 Enterprise NO NO NO NO
    Windows Server 2003 R2 Datacenter NO NO NO NO

    Windows Small Business Server 2003 is not supported
    Windows Server 2003 Web is not supported



    Windows Server 2008
    32 bit 64 bit
    SP2 SP2
    Windows Server 2008 Standard NO NO NO NO
    Windows Server 2008 Enterprise NO NO NO NO
    Windows Server 2008 Datacenter NO NO NO NO

    Windows Small Business Server 2008 is not supported
    Windows Web Server 2008 is not supported
    Windows Server 2008 HPC Edition is not supported



    Windows Server 2008 R2
    64 bit
    SP1
    Windows Server 2008 R2 Standard NO NO
    Windows Server 2008 R2 Enterprise NO NO
    Windows Server 2008 R2 Datacenter NO NO

    Windows Small Business Server 2008 is not supported
    Windows Server 2008 R2 Foundation is not supported.
    Windows Web Server 2008 R2 is not supported
    Windows Server 2008 R2 HPC Edition is not supported

    * recommended Operating system.

  • For more info about Windows memory limitation, please consult this table.

 

 


 

Store Visualizer for MAC

 

Operating System: Mac OS X 10.6 ("Snow Leopard") or higher

Processor and Memory: Intel Core 2 Duo or better, 4 GB RAM

Miscellaneous
2 button mouse (3 button mouse recommended)
250 MB free hard disk space

Graphics:
Minimum: Graphics card with 512 MB VRAM (1024 MB or higher recommended)
Ideal Configuration:
- Mac Pro with ATI Radeon 5870: This is the best card on Mac Pro today. But note that the hi-end PC cards can be up to 60% faster
- iMac 30” with AMD Radeon HD 6970M 2GB

 

 

 


 

Store Visualizer for PC

 

Operating System: Microsoft® Windows® XP, Windows® Vista or Windows® 7, 64 bit version recommended

 

 

Processor and Memory: 

 

Intel Pentium® 4 or higher, AMD Athlon® 64 or higher processor, 2 GB RAM (4 GB recommended)

Miscellaneous:
Two button mouse (3 button mouse recommended)
250 MB free hard disk space
PDF reader application (Adobe® Acrobat Reader, or similar)

Two button mouse (3 button mouse recommended) 250 MB free hard disk spacePDF reader application (Adobe® Acrobat Reader, or similar)

Graphics:
Minimum: OpenGL 3.0 compliant graphics card with 512 MB VRAM (1024 MB or higher recommended)
Ideal Configuration:
- NVidia Gforce GTX 780 with 3GB VRAM 

 

Notes 

  1. Although we don't expect issues with Microsoft OS patches, Esko only guarantees support on the official MS Service Pack (SP)level, not on individual OS patches. PC's for Esko applications (editors, rips or servers) must not be configured as WebServers (IIS), Network Domain Controllers (Active Directory), DNS Server, DHCP Server, WINS Server, SQL Server,  or MailServer. The Automation Engine Server is allowed to be a Member Server in a Windows Active Directory domain. However, Esko can not test all possible configurations. Contact your regional Customer Service Center in case of specific questions.
  2. Microsoft Windows Server Client Access Licenses: Make sure to purchase enough CAL's as required by the workflow (client PC, client Mac, Rip, Data server, etc...).
  3. The Automation Engine server and it's Assistant server should be dedicated Computers, no other software (both Esko (eg: FlexRip, FlexProof) and non-Esko) shall run on this machine.
  4. A single processor with hyperthreading enabled is considered as 2 processors for memory calculations. A dual core processor is considered as 2 processors for memory calculations.
  5. Esko software will only work with properly licensed versions of operating systems and other software. Esko is not responsible for any loss of functionality due to use with unlicensed software. Esko will not provide assistance in installing software on equipment lacking properly licensed software.